Pre-installed Windows 8 op een SSD zetten (laptop)

Door kakanox op woensdag 17 juli 2013 23:59 - Reacties (12)
Categorie: -, Views: 7.505

Ik had een computer nodig, had de afweging gemaakt tussen laptop en PC en vervolgens besloten voor een 15" laptop te gaan die ook als werkstation zou kunnen fungeren. Na lang en hard zoeken, vergelijken en reviews lezen gekozen voor een Acer Travelmate P253.

Deze TravelMate is een systeem uit de wat stevigere serie van Acer, robuust genoeg dus om zo nu en dan eens mee te nemen, en is opgebouwd om een vrij moderne Ivy Bridge Intel Core i3 3110M met 4GB DDR3. Microsoft Windows 8 (Standard Edition) staat standaard geÔnstalleerd op een voor z'n specs vrij vlotte maar in absolute zin enorm trage 5400 rpm 320GB Seagate harddisk.

Ik had nog een 160GB Lite-On SSD liggen die er uiteraard in moest, en heb deze dan ook gemonteerd met behulp van een HDD Caddy (trouwens zeer aan te raden, heb de eigenaren van de Nederlandse tak ook ontmoet toen ik een caddy moest ruilen. Geschikte lui, snelle levering, en enorm goedkoop! Ja, dikke plug, but worth it :) )

Uitgangspunt was een laptop met een pre-installed Windows 8 x64 NL, zonder enige vorm van installatiemedia. Ik ga jullie even niet vervelen met alle mislukte pogingen die ik gedaan heb om die Windows-installatie op de SSD te kopiŽren, installeren, recoveren, klonen, heksen, vermanend toe te spreken en nog veel meer.

(....even een paar avonden vooruit in de tijd...)

Uitermate storend - ik kreeg het systeem met geen mogelijkheid zo ver om te booten van mijn d.m.v. een HDDCaddy ingebouwde 160GB SATA3 SSD. Sterker nog, booten van iets anders dan de HDD wilde niet lukken zolang die ook in het systeem zat, en ik heb alle willekeurige knoppen geprobeerd om in het UEFI te komen maar de laptop boot gewoon Windows in.

De uiteindelijke oplossing was rigoreus, maar werkte, en wel als volgt:
- Haal de Windows 8 productsleutel uit je pre-installed installatie, mogelijk heb je deze nodig tijdens de clean install (ik heb hiervoor met succes BelArc Advisor gebruikt, maar heb niet gechecked op virussen/spyware/whatsoever gezien ik toch een schone install ging doen)
- Zorg dat je een System Builder Windows 8 DVD of ISO hebt (in mijn geval dus x64 non-Pro, alle talen staan op die system builder CD's).*
- Zet deze op een USB-stick met de bijgeleverde tool.
- Ga naar Start -> Instellingen (radertje) -> PC Instellingen Wijzigen -> Algemeen -> Geavanceerde Opstartopties -> Nu opnieuw opstarten
- Je komt dan in het recovery menu. Hier kan je onder (even uit m'n hoofd) geavanceerde opties aangeven dat je instellingen voor het UEFI wil wijzigen. De laptop herstart dan en je komt in het "BIOS".
- Hier zet je Secure Boot uit en schakel je de laptop om op Legacy BIOS modus ipv UEFI.
- De laptop herstart en zal booten van de USB stick. Je komt in je Windows 8 setup en deze zal weigeren te installeren op de oorspronkelijke harde schijf (i.v.m. de GPT partitietabel), maar ook op de SSD. Om de installatie te kunnen voltooien zal je alle partities op beide schijven moeten verwijderen
- Hierna: as normal. De laptop installeert volledig uit zichzelf, de productcode wordt bij de Acer TMP253 in ieder geval gewoon uit het UEFI gehaald, dus ik heb niks in te voeren.

Zet de instellingen in het UEFI achteraf weer even terug als je - net als ik - niet precies weet wat het inhoudt ;)

Succes!

* Een collega van me wist de Windows 8 x64 System Builder ISO voor me te krijgen (ik onderzoek nog even of het legaal is om deze in een torrent te gooien). Met de ISO die uit MSDN te downloaden is werkt het niet!

Volgende: Mijn bloed KOOKT! 08-'13 Mijn bloed KOOKT!

Reacties


Door Tweakers user i-chat, donderdag 18 juli 2013 00:51

heb je met boot-order geen last van het feit dat je ssd in een cady zit, ik zou namelijk gekozen hebben om de schijf in de cady te monteren en de ssd in de laptop... iets meer werk maar dan moet een standaard clone volgens mij gewoon 1 op 1 terug te zetten zijn?

Door Tweakers user kakanox, donderdag 18 juli 2013 00:56

i-chat schreef op donderdag 18 juli 2013 @ 00:51:
heb je met boot-order geen last van het feit dat je ssd in een cady zit, ik zou namelijk gekozen hebben om de schijf in de cady te monteren en de ssd in de laptop... iets meer werk maar dan moet een standaard clone volgens mij gewoon 1 op 1 terug te zetten zijn?
Ik heb zowel met m'n eigen SSD als met een 512GB SSD van een kennis geprobeerd te recoveren (na klonen). Mijn eigen SSD is te klein (de recoverypartitie staat aan het einde van de schijf, ik kreeg deze niet verplaatst), met de 512GB klaagt hij dat het volume niet geschikt is om naar te recoveren (of iets in die trant).

De SSD heb ik geprobeerd in de laptop zelf te monteren, maar daarvoor zou ik moeten modden gezien er twee pinnetjes zijn die schijven met een dikte > 7.5mm tegen houden in de daarvoor bestemde drivebay.

Alles werkt nu volledig naar behoren, maar er wordt inderdaad eerst naar de harddisk "gekeken" die vervolgens naar de SSD verwijst. Als ik de harddisk eruit haal boot de laptop niet meer, which is fine with me.

Door Tweakers user Blokker_1999, donderdag 18 juli 2013 05:41

Uitermate storend - ik kreeg het systeem met geen mogelijkheid zo ver om te booten van mijn d.m.v. een HDDCaddy ingebouwde 160GB SATA3 SSD. Sterker nog, booten van iets anders dan de HDD wilde niet lukken zolang die ook in het systeem zat, en ik heb alle willekeurige knoppen geprobeerd om in het UEFI te komen maar de laptop boot gewoon Windows in.
Als tweaker had je ondertussen toch al moeten weten dat W8 hier de schuldige is. Door het fastboot principe krijg je geen enkele mogelijkheid meer om tijdens het booten het opstartproces af te breken, dit omdat het booten van de uefi zo enorm snel gaat. Enkele weken terug was er op de FP nog een artikel over te vinden dat men het niet vinden kon dat er geen mogelijkheid bestaat om op een UEFI systeem in de UEFI te gaan zonder eerst windows te installeren (behalve dan als men de HDD verwijderde).

Door Tweakers user kakanox, donderdag 18 juli 2013 07:47

Blokker_1999 schreef op donderdag 18 juli 2013 @ 05:41:
[...]
Als tweaker had je ondertussen toch al moeten weten dat W8 hier de schuldige is. Door het fastboot principe krijg je geen enkele mogelijkheid meer om tijdens het booten het opstartproces af te breken, dit omdat het booten van de uefi zo enorm snel gaat. Enkele weken terug was er op de FP nog een artikel over te vinden dat men het niet vinden kon dat er geen mogelijkheid bestaat om op een UEFI systeem in de UEFI te gaan zonder eerst windows te installeren (behalve dan als men de HDD verwijderde).
Hmm, ik geloof niet dat je iemand aan kan spreken op het feit dat ie zich aangemeld heeft op een bepaalde website ;)
Dit is pas mijn tweede systeem met Windows 8 en ik heb zeker niet alle kennis in huis m.b.t. OS'en. Proberen bij boot een BIOS of UEFI te benaderen is bij mij heel normaal, als dat niet lukt ga ik verder proberen zoals hier.

[Reactie gewijzigd op donderdag 18 juli 2013 08:34]


Door Tweakers user Luuk1983, donderdag 18 juli 2013 12:08

Ik heb inderdaad drie mogelijkheden in de UEFI van mijn server:
  • Normaal boot, zoals het altijd was, je kan gewoon in de UEFI komen en booten vanaf USB.
  • Fast boot, start al wat sneller op, maar je hebt nog wel de mogelijkheid om de bios te benaderen, maar niet op vanaf USB-devices op te starten.
  • Ultra fast boot: skipped nagenoeg alles van de bios/uefi en start daardoor verschrikkelijk snel op. De enige manier om nog in de UEFI te komen is door de jumper op het moederbord te verzetten en de UEFI te resetten.

Door Tweakers user Eagle Creek, donderdag 18 juli 2013 16:25

Ga naar Start -> Instellingen (radertje) -> PC Instellingen Wijzigen -> Algemeen -> Geavanceerde Opstartopties -> Nu opnieuw opstarten
Waarom zo omslachtig?

Door Tweakers user kakanox, donderdag 18 juli 2013 16:36

Hoe zou jij dat anders doen? Het zijn maar een paar muisklikken, ik vind het best een snelle manier om daar te komen.

Door Tweakers user The Cageman, donderdag 18 juli 2013 20:56

Dit is inderdaad een bekend moeilijk punt bij het installeren van windows 8 met UEFI. Heb er zelf ook veel 'lol' mee gehad op m'n werk voor de eerste keer, maar dit is niet onbekend en is prima te vinden op internet. Wat wel slecht is is dat dit nergens uitgelegd wordt en wij dus als eerste moesten proberen maar wat te veranderen in de hoop dat dat wel werkt.

Door Tweakers user M.l., donderdag 18 juli 2013 21:59

Misschien is het mogelijk om eens te kijken wat de verschillen zijn t.o.v. een andere meer gebruikte ISO. Als je alleen het verschil deelt zou men de werkende ISO weer op kunnen bouwen.

Door Tweakers user Eagle Creek, donderdag 18 juli 2013 22:13

Het komt er toch gewoon op neer dat je in het UEFI aan moet geven legacy BIOS te willen hebben en klaar? Ik zie tal van handleidingen en frustraties tegenkomen maar in essentie is het vrij eenvoudig - toch?

Door Tweakers user gwystyl, donderdag 18 juli 2013 22:30

M.l. schreef op donderdag 18 juli 2013 @ 21:59:
Misschien is het mogelijk om eens te kijken wat de verschillen zijn t.o.v. een andere meer gebruikte ISO. Als je alleen het verschil deelt zou men de werkende ISO weer op kunnen bouwen.
Bij een torrent die ik net snel gevonden had stond dat hij geschikt was voor OEM-systemen van o.a. acer, dell, hp enz. Daar zat geen key bij, omdat die vaak in de BIOS/UEFI ingebakken zit.
Retail iso's die je kan vinden of downloaden van MSDN zijn in principe op alle systemen te installeren volgens mij.

Door Tweakers user kakanox, vrijdag 19 juli 2013 00:47

Eagle Creek schreef op donderdag 18 juli 2013 @ 22:13:
Het komt er toch gewoon op neer dat je in het UEFI aan moet geven legacy BIOS te willen hebben en klaar? Ik zie tal van handleidingen en frustraties tegenkomen maar in essentie is het vrij eenvoudig - toch?
Het is vooral ingewikkeld omdat het dus vrijwel niet mogelijk lijkt te zijn om de schijf te klonen en het op die manier werkend te krijgen. Of dat specifiek is voor het Acer-image weet ik niet, ik weet vooral dat het ongenadig irritant is.
gwystyl schreef op donderdag 18 juli 2013 @ 22:30:
[...]

Bij een torrent die ik net snel gevonden had stond dat hij geschikt was voor OEM-systemen van o.a. acer, dell, hp enz. Daar zat geen key bij, omdat die vaak in de BIOS/UEFI ingebakken zit.
Retail iso's die je kan vinden of downloaden van MSDN zijn in principe op alle systemen te installeren volgens mij.
De retail ISO weigert dus zowel te downloaden als te installeren met mijn OEM key. Wat de oorzaak daarvan is weet ik niet.

Ik heb inderdaad ook nog 2 andere OEM images gevonden. Eťn daarvan is m'n virusscanner alles behalve blij mee, lijkt aardig aangepast te zijn (helaas is een SHA1 van het OEM-image vinden ook niet echt een optie), de andere komt niet helemaal binnen (via de .torrent).
M.l. schreef op donderdag 18 juli 2013 @ 21:59:
Misschien is het mogelijk om eens te kijken wat de verschillen zijn t.o.v. een andere meer gebruikte ISO. Als je alleen het verschil deelt zou men de werkende ISO weer op kunnen bouwen.
Ik heb geen idee hoe ik dat aan moet pakken, zo'n enorme OS-techniker ben ik niet. Het enige dat ik constateerde is dat er op allerlei plaatsen vooral mensen te vinden zijn die problemen hebben met het installeren van W8 op een verse SSD bij OEM-installaties, ik heb bovenstaande (vrij bondige) handleiding geschreven om anderen wat ergernis te besparen.

[Reactie gewijzigd op vrijdag 19 juli 2013 00:50]


Reageren is niet meer mogelijk